Issue
- "Token invalid" message when resetting password
Environment
- Any browser
Resolution
- Make sure you are using Google Chrome or Firefox
- Go to your email and delete any Password Reset emails from Shadow Health
- Go to Shadow Health login page and go through password reset process again
Cause
When you try to change your password, an email is sent to you with a link to change it. This link will only work once as a security feature. If you try to use it a second time or if enough time passes, this error message is what you will see.